Cette page traite des problèmes d'authentification avec Microsoft Entra ID (Azure AD) et les informations d'identification SQL Server.
Problèmes d'authentification Microsoft Entra
Erreur : « AADSTS700016 : l'application avec l'identifiant « X » est introuvable »
Cause : l'ID client (ID d'application) est incorrect ou l'enregistrement de l'application n'existe pas
Solutions :
1. Dans le portail Azure, accédez à Azure Active Directory → Enregistrements d'applications
2. Recherchez votre application et copiez l'ID d'application (client)
3. Collez la valeur correcte dans le champ ID client
Erreur : « AADSTS90002 : Locataire « X » introuvable »
Cause : l'ID du locataire (ID du répertoire) est incorrect
Solutions :
1. Dans le portail Azure, accédez à Azure Active Directory → Présentation
2. Copiez l'ID du locataire (ID du répertoire) dans la section Essentiels
3. Collez la valeur correcte dans le champ ID du locataire
Erreur : « AADSTS7000215 : secret client invalide fourni »
Cause : le secret client est incorrect ou a expiré
Solutions :
1. Dans le portail Azure, accédez à votre enregistrement d'application → Certificats et secrets
2. Vérifiez si le secret a expiré (consultez la colonne Expires)
3. Créez un nouveau secret client et copiez la valeur (pas l'ID secret).
4. Mettez à jour le champ Client Secret dans DvSchemaSync
⚠ Important : les valeurs du secret client ne peuvent être consultées qu'une seule fois après leur création. Si vous ne l'avez pas enregistré, vous devez créer un nouveau secret.
Erreurs d'autorisation Dataverse
Erreur : « 403 Forbidden » ou « Insufficient permissions »
Cause : l'utilisateur de l'application ne dispose pas du rôle de sécurité requis
Solutions :
1. Dans le centre d'administration Power Platform, accédez à votre environnement → Paramètres → Utilisateurs
2. Recherchez l'utilisateur de l'application pour l'enregistrement de votre application
3. Attribuez le rôle de sécurité Administrateur système (pour les opérations de synchronisation)
4. Pour la génération de données factices, assurez-vous également que l'utilisateur dispose des autorisations de création sur les entités cibles
Problèmes d'authentification SQL Server
Erreur : « Échec de la connexion pour l'utilisateur « X » »
Causes possibles :
• Nom d'utilisateur ou mot de passe incorrect
• L'utilisateur n'a pas accès à la base de données spécifiée
• Authentification Azure AD requise, mais tentative d'authentification SQL
Solutions :
1. Vérifiez que les informations d'identification sont correctes
2. Assurez-vous que l'utilisateur dispose d'un accès à la base de données
3. Essayez de passer à l'authentification Microsoft Entra si elle est disponible